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Troubleshooting
An issue/error is an unexpected behavior in a system that has a documented root cause and a workaround/solution.
Name of the error/issue Copied
Provide a descriptive title that summarizes the whole error.
# Tech Comms-only tags:
title: "Failure to complete a large bulk edit"
draft: false
Problem Copied
Describe how the issue or error happened. If applicable, you can include a screenshot of the error.
## Problem
When attempting bulk edits within Opsview across numerous hosts, the process fails to complete. In the Opsview logs, on master, you should see any entries with "caught deadlock" error.
Cause Copied
Answers the following questions:
- Why does this issue/error occur?
- At what circumstances it usually occurs?
- What are the symptoms of this issue/error?
- If there is only one cause, explain the cause here. If there are multiple causes, consider listing them.
## Cause
The deadlock comes from the MySQL/MariaDB database.
Solution Copied
Detail the steps on how to solve the issue/error. If there is more than one solution, consider listing them.
- Solution 1
- Solution 2
- Solution 3
You can add diagrams, screenshots, and code samples to make each step clearer. In addition and if applicable, use notes, warnings, or tips to highlight any important information that users must know about. For more information, see the Markdown Style Guide.
## Solution
To solve the error, increase the `innodb_lock_wait_timeout` parameter. To do this, follow the steps below:
1. Log into MySQL or MariaDB and run the following to capture the current setting.
`MySQL [(none)]> show global variables like '%innodb_lock_wait_timeout%';`
+--------------------------+-------+
| Variable_name | Value |
+--------------------------+-------+
| innodb_lock_wait_timeout | 50 |
+--------------------------+-------+
2. Increase the value to 120 seconds (2 mins).
`MySQL [(none)]> SET GLOBAL innodb_lock_wait_timeout = 120;`
Related Resources Copied
Provide links to related documents.
## Related resources
For more information, see related articles:
Contact us Copied
Provide a link to contact the Support Team.
## Contact us
For more inquiries, reach out to us by:
- Submitting a ticket through our [Support portal](https://support.itrsgroup.com/hc/en-us/requests/new)
- Using the chat service box available across our website.
Sample Copied
---
# Tech Comms-only tags:
title: "Failure to complete a large bulk edit"
draft: false
# Algolia labels:
algolia:
Component: [
"Opsview > Monitor"]
ContentType: [
"User Guide"]
---
## Problem
When attempting bulk edits within Opsview across numerous hosts, the process fails to complete. In the Opsview logs, on master, you should see any entries with "caught deadlock" error.
## Cause
The deadlock comes from the MySQL/MariaDB database.
## Solution
To solve the error, increase the `innodb_lock_wait_timeout` parameter. To do this, follow the steps below:
1. Log into MySQL or MariaDB and run the following to capture the current setting.
`MySQL [(none)]> show global variables like '%innodb_lock_wait_timeout%';`
+--------------------------+-------+
| Variable_name | Value |
+--------------------------+-------+
| innodb_lock_wait_timeout | 50 |
+--------------------------+-------+
2. Increase the value to 120 seconds (2 mins).
`MySQL [(none)]> SET GLOBAL innodb_lock_wait_timeout = 120;`
## Related resources
For more information, see related articles:
- [Link title](/[section folder]/[topic-name]/)
## Contact us
For more inquiries, reach out to us by:
- Submitting a ticket through our [Support portal](https://support.itrsgroup.com/hc/en-us/requests/new)
- Using the chat service box available across our website.
["Geneos"]
["Geneos > Gateway"]
["User Guide"]